Knowledgebase: Server Administration
How to upgrade from pre-2.5 to 2.5 or later
Posted by Mont Rothstein on 25 November 2008 05:44 PM

How to upgrade from 2.0-2.2 to 2.5 or later

This article explains how to upgrade an ADAMS server based installation (i.e. one that has a server and at least one workstation) from a release in the 2.0-2.2 range to a release version 2.5 or later. This process is required because in addition to the normal upgrade process a database software upgrade is needed.
  1. Prepare for the upgrade
    1. Check the version of your system by opening Digital Workplace and going to Help->About. If the version is less than or greater than then this is not the correct process for your system. In that case stop here, otherwise go on to the next step.
    2. Download the latest version of ADAMS to your Windows workstation. Get the URL and password from support.
    3. Have everyone exit all ADAMS applications. They will need to stay out of the system for the duration of this process.
    4. Make sure you have a full backup since everyone exited ADAMS. Because of this it may be easiest to do this first thing in the morning, after you have a full backup from the night before and no one was in the system.
    5. You will need the following passwords. You may need to request these from Foray support:
      1. For Linux based servers:
        1. root account password
      2. For Windows based servers:
        1. An account with local administrator privileges
        2. The postgres Windows service account password
        3. The postgres database superuser account password
  2. Upgrade the database software
    1. If your server has internet access then you can login as the root account (on Linux) or as an account with local admin privileges (on Windows) now. Otherwise you will need to download the zip file below from a computer with internet access and transfer it to the server.
    2. For Linux based servers download the following zip file:

    3. For Windows based servers download the following zip file:

    4. If you have not already done so login:
      1. On Linux login as root
      2. On Windows login as an account with local admin privileges
    5. Extract the zip
      1. On Linux
        1. Double click
        2. In the window that opens (titled: click Extract
        3. In the Extract window click Extract
        4. When the extraction is done close the window titled:
        5. Double click to open the PostgreSQL_Upgrade_8.3.5_Linux folder on the desktop
      2. On Windows
        1. Right-click
        2. Click Yes if presented with a security warning
        3. Select Extract All from the menu
        4. Click Next
        5. Click Next
        6. Click Finish
        7. Double click to open the PostgreSQL_Upgrade_8.3.5_Windows folder on the desktop
    6. Upgrade the database software
      1. Double-click the README.txt
      2. Follow the instructions
  3. Upgrade the ADAMS software
    1. Uninstall all ADAMS software from the workstation. This may include any or all of the following:
      1. AFIS Connect
      2. Digital Acquire
      3. Digital Viewer
      4. Digital Workplace
    2. Install the new version of the ADAMS software. Note: you will only be installing some of the files contained within the ADAMS zip fie that was downloaded.
      1. Right-click on the ADMAS zip file that you downloaded
      2. Click Yes if presented with a security warning
      3. Click Next
      4. Click Next
      5. Enter the zip file password provided by support
      6. Click OK
      7. Click Finish
      8. Install the new versions of the applications you uninstalled
      9. Install Configure ADAMS
    3. Upgrade the Repository
      1. Run Start->Foray->Configure ADAMS
      2. Click Load Central Config
      3. Read each dialog, answer the questions, and fill in any requested data.
      4. When the upgrade has completed you can close Configure ADAMS and open Digital Workplace to verify that everything is working.
    4. Upgrade any other workstations by uninstalling any existing ADAMS software and installing the new versions.

Comments (0)