Knowledgebase: Scanners
Epson Scanner Failure
Posted by David Witzke on 25 September 2007 08:49 PM

Upon attempting to run the Epson Scanner software in Digital Workplace, Digital Acquire or Adobe Photoshop using either the standard Epson interface, the scanner would fail to initialize and respond with one of the following messages (the physical memory address would change each time I started the application):

Escndv.exe  Application error.
The instruction at 0x10070e51 reference memory at 0x001e9000. The memory could not be written.
Click on OK to terminate the program.

Escndv.exe  Application error.
The instruction at 0x77f69d63 reference memory at 0xe0e0edbde. The memory could not be read.
Click on OK to terminate the program.


This problem will occur sporadically, and often without rhyme or reason.

Even though it responds with an ESCNDV.EXE  Application error message, the problem is that the software cannot read the last scanned image, which is displayed in the preview window when the application starts.


The default configuration value is to display last scanned image, which is what causes the problem. If you change the preview configuration to not display the last scanned image, the problem "should" not occur.

 
However, once you get the error message, there is only one known fix. You must:
 

Go to C:\Documents and Settings\[user]\Application data\EPSON and DELETE the contents of that folder.

For example, on my computer, the Epson scanner saves the last preview in a file entitled: FULL.bmp. So I have to go to C:\Documents and Settings\David Witzke\Application Data\EPSON\ and then delete the ESCNDV subfolder which contains yet another subfolder ES0052 with the image file FULL.bmp.

Theoretically, once you delete that file, things "should" work again properly without problem. HOWEVER, with laptops, this problem typically occurs each time the laptop is disconnected from the scanner and the laptop is subsequently reconnected back to the scanner.

With all of the traveling that I do and the scanner being connected, then disconnected, and then reconnected, this problem typically would recur again when I reconnected the scanner to my laptop. So I keep having to go back into the folder and delete the file.


Comments (0)