Knowledgebase
Troubleshoot Adams Upload
Posted by Diane Hancock on 12 April 2018 10:15 AM

When the assets captured by Adams Upload do not appear in Adams Web, check the following.

Phone

  • Registered? (see Info page)
  • last connection time recent? (see Info page)
  • Device Gateway url is correct? (see Info page)  If not, change in Digital Workplace, restart Adams Admin and re-register the phone.
  • HTTPS or phone is on the same network as Device Gateway?
  • Scene closed?
  • Does Adams Upload have a bubble with a number? If so, Asset transmission has not completed.

Device Gateway server

  • Server is available?
  • Event viewer errors?
  • Files appearing in DeviceGatewayUploads directory or metadata subdirectory?
  • Repository owner and Device Gateway app pool user on DeviceGatewayUploads directory?
  • Enable logging (web.nlog and create Logs directory) to see what communication if any is happening

Acquisition Service

  • Running?
  • Mobile Acquisition enabled?
  • Watch folder is DeviceGatewayUploads path (use UNC notation with share if on another machine)?
  • Files appearing in DeviceGatewayUploads\metadata directory with _DONE suffix?  If files without suffix, then transmission is not completing.  See Device Gateway service logging and Restart section.

Adams Admin > Application Status > Adams Upload application for the Device

  • Action = UploadFirstFragment?  If not, see the Device Gateway logs.
  • Last communication date/time is when the scene was closed or more recent?  If not, then see the Device Gateway logs.

Restart

  • Adams Upload
  • Router

 


Comments (0)