Knowledgebase
Error launching Digital Workplace
Posted by Scott Friend on 12 July 2016 03:43 PM

When starting Digital Workplace you get the following error.

 

---------------------------

Error

---------------------------

An error has occurred.  Please type Ctrl-C to copy the contents of this window, paste it into an email, and send it to support@foray.com

 

 

7/12/2016 3:06:53 PM - Foray Digital Workplace 5.3.3.13

 

 

 

 

   at Foray.Adams.FASystem.WriteEventLogEntry(String message, Exception exception, EventLogEntryType eventType)

   at Foray.Adams.FASystem.UncaughtExceptionMessage(Exception exception)

   at Foray.Adams.Forms.ThreadHandlerUI.HandleException(Exception exception)

   at Foray.Adams.DigitalWorkplace.AppController.OnUnhandledException(UnhandledExceptionEventArgs eventArgs)

   at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel()

   at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(String[] commandLine)

   at Foray.Adams.DigitalWorkplace.AppController.Main(String[] args)

 

 

This build of the utility has not been processed using the preptool.

 

 

   at FlexNet.CommonLibrary.InitializeLibrary()

   at FlexNet.CommonLibrary.CreateApplicationLibrary()

   at FlexNet.ActivationUtility..ctor()

   at FlexNet.ActivationUtility.get_Instance()

   at Foray.Adams.Activation.FAActivation.get_ActivationUtilityInst()

   at Foray.Adams.Activation.FAActivation.PrepareActivationLibrary()

   at Foray.Adams.Activation.FAActivation.CheckOut(String feature, String version, Int32 quantity, String sessionId)

   at Foray.Adams.DigitalWorkplace.AppController.OnCreateMainForm()

   at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.OnRun()

   at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel()

 

 

 

---------------------------

OK  

---------------------------  

 

 

The issue is that the registry has some older versions of two DW dlls (lmgract.dll and lmgract_libFNP.dll), which causes a mis-match of the libraries when I was testing and going from one version to another (within the same version).  To fix this issue, uninstall Digital Workplace, delete all of the files from the DW directory, delete the registry values and re-install.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\SharedDLLs

EX: C:\inetpub\wwwroot\AdamsWeb\bin\lmgract.dll

 


Comments (0)